본문 바로가기

컴퓨터와 인터넷/리눅스

ERROR 1819 (HY000): Your password does not satisfy the current policy requirements 해결

반응형

MySQL 유저생성시에 ERROR 1819 (HY000): Your password does not satisfy the current policy requirements 라는 에러가 나온다면?


해결방법은?

아마도 MySQL 5.7 버전일 것으로 본다.

ERROR 1819 (HY000): Your password does not satisfy the current policy requirements


#mysql -u root -p

#use mysql;

아래 쿼리로 확인을 해보자

mysql>SHOW VARIABLES LIKE 'validate_password%'; 




확인 결과 비밀번호 길이가 8자리 이상이어야 하며 대소문자를 섞어써야 하게끔 보안설정이 되어 있어서였다.


MySQL 5.7.9 설치시 참고해야할 사항

http://diveis.tistory.com/149



MySQL 5.7x중에서도 5.7.9부터는 mysql.user 테이블의 password 필드명이 authentication_string으로 

   변경됐다. 또 password_expired, password_last_changed, password_lifetime, account_locked 필드가 

   추가되어 패스워드 기간 등에 대한 제어가 가능하다.


반응형